Delay with subtickets being created
Incident Report for SweetHawk
Resolved
The issue was found to be a large number of requests originating from a task list being added to a ticket which itself was created as a result of the same task list, resulting in a continuous amount of requests being created. Our server could not handle this situation for a prolonged period of time. We've now implemented a feature that prevents a task list from being added to a ticket automatically if that ticket itself was created as a result of the same task list. This new restriction only applies to task lists being added automatically via trigger/target, not manually. This will prevent our server from being exposed to excessive and unnecessary jobs. We've also increased our server's capacity to work through larger number of requests faster.
Posted 19 days ago. Aug 29, 2019 - 02:39 UTC
Monitoring
The worker queue responsible for creating subtickets within the Tasks app has been cleared and we're working on the root cause. Please subscribe to this incident to be kept in the loop on a resolution.
Posted 19 days ago. Aug 28, 2019 - 21:54 UTC
Investigating
We found an issue with the Tasks app where subtickets are not created instantly, we're looking into it. We expect all subtickets to be created correctly upon resolution.
Posted 19 days ago. Aug 28, 2019 - 21:31 UTC
This incident affected: App server (zendesk.sweethawk.co) (Tasks).